Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 14, 2024 - 20:00 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 14, 2024 - 09:10 EST
Scheduled
This message is intended for InterQual® Customize customers.
We are pleased to announce the November 2024 release of InterQual® Customize, which includes these updates:
• Ability to add and edit abbreviations & terms • InterQual® Specialty Referral customization updates
These changes will be deployed to the production environment on Thurs., Nov. 14, 2024, between 8 p.m. ET and 9 p.m. ET. The application will be available while these updates are deployed, though users may experience degraded performance during the maintenance window.
Contact information For additional information or assistance, submit a support case through Customer Care Hub.
REF 818650
Posted Nov 13, 2024 - 18:17 EST
This scheduled maintenance affected: Clinical Decision Support (InterQual® Customize).