Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 14, 2024 - 21:01 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 14, 2024 - 09:16 EST
Scheduled
This message is intended for InterQual® Coordinated Care customers.
The InterQual® Coordinated Care production environments will be unavailable due to maintenance on Thurs., Nov. 14, 2024, at 9 p.m. ET for approximately 1 hour. Customers should plan to stop their work before 9 p.m. ET or their session will be interrupted.
We appreciate your support and apologize for any inconvenience this may cause.
Updated Maintenance Schedule Begin: Nov. 14, 2024, 9 p.m. ET End: Nov. 14, 2024, 10 p.m. ET
Contact Information For any additional information submit a support case through the Customer Care Hub.
REF818100
Posted Nov 13, 2024 - 18:10 EST
This scheduled maintenance affected: Clinical Decision Support (InterQual® Coordinated Care).