Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 15, 2025 - 21:00 EDT
Update
Reminder: Clearance Patient Access Suite will be conducting server maintenance on May 15th at 9 p.m. EST through 1 a.m. EST. During this period, Clearance will not be available. Once the maintenance is complete, you may experience reduced performance for up to an hour as back-end services return to full speed.
Action required: Please alert any staff that this might impact.
Posted May 15, 2025 - 13:37 EDT
Scheduled
Clearance Patient Access Suite will be conducting server maintenance on May 15th at 9 p.m. EST through 1 a.m. EST. During this period, Clearance will not be available. Once the maintenance is complete, you may experience reduced performance for up to an hour as back-end services return to full speed.
Action required: Please alert any staff that this might impact.