Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 10, 2025 - 20:00 EDT
Scheduled
We are pleased to announce the April 2025 release of InterQual® Customize, which includes these updates:
• Site of service details can now be enabled for custom Q&A subsets • User Interface improvements, such as the left-side toolbar being expanded by default
These changes will be deployed to the production environment Thursday, April 10, 2025, 8:00 p.m.-9:00 p.m. ET. The application will be available while these updates are deployed, though users may experience degraded performance during the maintenance window.
For additional information or assistance, sign in to the Customer Care Hub and submit a new case to Product Support.
REF 17203409
Posted Apr 10, 2025 - 12:18 EDT
This scheduled maintenance affected: Clinical Decision Support (InterQual® Customize).