Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 13, 2024 - 23:00 EST
Scheduled
The InterQual® Cloud Solutions system will be undergoing routine database maintenance during the maintenance window below:
Start: Dec. 13, 2024, 11 p.m. ET End: Dec. 14, 2024, 2 a.m. ET
The InterQual® Cloud Solutions production environment (https://prod.ds.interqual.com) will be available during this maintenance window, though users may experience degraded performance while maintenance activities are occurring.
REF 15589302
Posted Dec 10, 2024 - 16:42 EST
This scheduled maintenance affected: Clinical Decision Support (InterQual® Cloud Solutions).