We are pleased to inform you that the issue affecting Clinical Exchange has been resolved.
#INC48489210
Posted Feb 18, 2026 - 12:33 EST
Identified
The Clinical Exchange team is aware of an issue impacting some laboratory customers . We continue to actively work on resolving the issue as quickly as possible.
#INC48489210
Posted Feb 18, 2026 - 12:04 EST
Investigating
The Clinical Exchange team is aware of an issue impacting some laboratory customers . We are working to resolve the issue as quickly as possible.