We are pleased to inform you that the issue affecting the Clinical Exchange applications has been resolved. Thank you for your patience and understanding while we worked to resolve this matter
Posted Mar 20, 2025 - 14:18 EDT
Investigating
Some Clinical Exchange customers may be experiencing connectivity issues or slowness when creating lab orders. We are working on a resolution and will keep you posted as additional information is available. #INC0701254
Posted Mar 20, 2025 - 13:12 EDT
This incident affected: Clinical Network (Clinical Exchange Channel Partners including ePrescribe and Orders & Results, Clinical Exchange Labs and Hospitals).