Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 17, 2025 - 10:00 EDT
Scheduled
This message is intended for Clearance Patient Access, Clearance EDI, AhiQA and Medical Network customers.
CMS advises HETS Submitters that CMS IT will be conducting a maintenance update Saturday, May 17, 2025, 10:00 a.m.-2:00 p.m. ET. While this maintenance should not impact availability or performance of the Medicare HETS 270/271 eligibility system, we are notifying HETS Submitters in case you notice any impact. The HETS 270/271 system should remain available during maintenance.
Action Required: Review and distribute notification as appropriate within your facility.
REF 17615708
Posted May 13, 2025 - 09:44 EDT
This scheduled maintenance affected: Medical Network Services (eligibility, enrollment and clearinghouse) (Remittance/ERA transmission, Real-time eligibility transactions) and Revenue Cycle Management (Ahi Lobby, AhiQA, Clearance Patient Access Suite).