Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved: ACCUREG - ENGAGECARE PROVIDER : Eligibility verification is not being returned for all customers using the Engage Care Provider product.

Incident Report for Optum Solutions

Resolved

Engage Care Provider Services have been restored. Teams are working to reprocess Eligibility transactions.
Posted Feb 05, 2026 - 16:15 EST

Investigating

02/05/2025 [03:01:00 PM EST]

The Engage Care Provider team is currently experiencing a processing issue for EV/Eligibility services. Teams are engaged and working to resolve the issue as quickly as possible.

INC48241580
Posted Feb 05, 2026 - 15:03 EST
This incident affected: Patient Financial Clearance (EngageCare Provider).