Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice: MEDRX – Issue with the Claim Management Utility Tool

Incident Report for Optum Solutions

Resolved

The issue with the Claim Management Utility tool is now resolved.

INC/CSA/Ref #INC48291819
Posted Feb 09, 2026 - 10:41 EST

Identified

We are still investigating and will provide an update as soon as possible.

INC/CSA/Ref #INC48291819
Posted Feb 09, 2026 - 09:52 EST

Investigating

MedRx Optum Insight is currently experiencing an issue with the Claim Management Utility tool. We are investigating and will provide an update as soon as possible.

INC/CSA/Ref #INC48291819
Posted Feb 09, 2026 - 08:51 EST
This incident affected: Pharmacy Solutions (MedRx).