For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Ongoing Incident: Clinical Decision Support – Review Manager Hosted Solutions

Incident Report for Optum Solutions

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted May 08, 2025 - 15:29 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted May 07, 2025 - 16:07 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted May 06, 2025 - 16:43 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted May 05, 2025 - 15:23 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted May 02, 2025 - 15:22 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted May 01, 2025 - 15:16 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 30, 2025 - 15:24 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 29, 2025 - 15:42 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 28, 2025 - 14:20 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is continuing to actively investigate this issue. We will provide the next update on Monday, April 28, 2025.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 25, 2025 - 14:06 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 24, 2025 - 15:12 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 23, 2025 - 16:00 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 22, 2025 - 15:31 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 21, 2025 - 15:51 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is continuing to actively investigate this issue. We will provide the next update on Monday, April 21, 2025.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 18, 2025 - 13:58 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 17, 2025 - 16:04 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 16, 2025 - 15:39 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is continuing to actively investigate this issue. We will provide daily updates and notify you immediately as soon as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 15, 2025 - 14:00 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as soon as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 14, 2025 - 15:10 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is continuing to actively investigate this issue. We will provide the next update on Monday, April 14, 2025.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 11, 2025 - 15:32 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is continuing to actively investigating this issue. We will provide daily updates and notify you immediately as soon as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 10, 2025 - 15:45 EDT

Update

We have received reports of slowness in the Hosted Review Manager application. Please be assured that our team is actively investigating this issue. We will provide daily updates and notify you immediately as soon as more information becomes available.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience and understanding.
Posted Apr 09, 2025 - 15:23 EDT

Investigating

There have been reports that Hosted Review Manager customers are experiencing slowness in the application. We are investigating the incident and will provide an update when more information is available. We apologize for the inconvenience this situation has caused you.


REF 17188998
Posted Apr 08, 2025 - 16:45 EDT
This incident affects: Clinical Decision Support (InterQual® Review Manager – Hosted).