This issue has been resolved. Performance has returned to optimal levels. Support will resume all impacted jobs for hosted clients. For Turnkey clients, please resume any failed jobs. If you have any questions, please contact Support.
Action Needed: Please reinstate the automated password changes in Assurance if you disabled them. If you are still experiencing issues with your password, please contact Medicare to reset your password and update the information within Assurance.
#INC48776620
Posted Mar 06, 2026 - 09:02 EST
Identified
Customers continue to experience slowness and errors with Medicare Direct Entry. A fix is in review and will be distributed tonight.
#INC48776620
Posted Mar 05, 2026 - 15:15 EST
Update
Customers may continue to experience slowness and errors with Medicare Direct Entry jobs. The technical team is actively working to resolve the issue. We will provide further updates as more information becomes available at 2:00 PM CST.
#INC48776620
Posted Mar 05, 2026 - 13:39 EST
Update
Customers may continue to experience slowness and errors with Medicare Direct Entry jobs. Research towards resolution continues.
#INC48776620
Posted Mar 05, 2026 - 11:26 EST
Update
Customers may experience errors with Medicare Direct Entry processing. Resolution efforts are in process.
Posted Mar 04, 2026 - 18:28 EST
Update
Customers have been provided a workaround for the password issue by disabling the automated DE password update and manually updating the password on the Medicare system. Optum continues to work on the root problem.
INC # INC48750170
Posted Mar 04, 2026 - 14:33 EST
Update
Customers may experience slowness or errors with Medicare Direct Entry jobs. Optum continues to research.
INC # INC48750170
Posted Mar 04, 2026 - 11:36 EST
Investigating
Customers may experience performance issues or errors on Direct Entry jobs due to password issues.
INC # INC48750170
Posted Mar 04, 2026 - 10:35 EST
This incident affected: Revenue Cycle Management (Assurance Reimbursement Management).