For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved notice - Pharmacy Solutions Websites

Incident Report for Optum Solutions

Resolved

This is a notification that there was a brief connection issue for customers attempting to connect to the MedRx and Network websites at approximately 11:30CT. This issue has been resolved
Posted Feb 27, 2025 - 13:11 EST
This incident affected: Pharmacy Solutions (MedRx, Rx Secure Site).