The Clinical Exchange application is back online and all transactions are processing as expected. We will continue to monitor the application. The root cause was related to an AWS update that was reverted, and an official RCA document will be provided after a full internal review is completed. If you experience issues logging in, please log out and log back into the application.
INC/CSA/Ref #INC0738379
Posted Jul 01, 2025 - 11:03 EDT
Monitoring
The Clinical Exchange application is back online. Results processing efforts started at approximately 5 AM Central and results are being delivered to customers. We will continue to monitor the application. The root cause was related to an AWS update that was reverted. If you experience issues logging in, please log out and log back into the application.
Posted Jul 01, 2025 - 10:21 EDT
Update
The application is still unavailable. We are continuing our restoration efforts regarding the Clinical Exchange application. The incident started at 3 AM central and the root cause is related to an update applied to our AWS servers. The update was reverted and application restoration is in progress. This does impact all application access - lab orders and results and e-prescribe and SST.
Posted Jul 01, 2025 - 09:13 EDT
Identified
The application is still unavailable. This is impacting all functionality on Clinical Exchange, lab orders and results and e-prescribe.
INC/CSA/Ref #INC0738379
Posted Jul 01, 2025 - 08:03 EDT
Investigating
The Clinical Exchange application is currently experiencing an outage. The application is currently unavailable, and restoration is in progress. Start time = 3 am CST