3-14-2026 there was a critical connectivity issue affecting transactions routed to Prime Therapeutics / Magellan. The issue is resulted in connection‑to‑payer errors and preventing successful claim processing for impacted plans. Optum teams engaged with Prime and connectivity is restored on 3-14-2026 at 2:10pm CST. Please resubmit any impacted claims.
BIN 022659- resolved BIN 009737/ 011503- resolved BIN 002286- resolved
INC #INC48943150
Posted Mar 14, 2026 - 15:42 EDT
Update
Issue Ongoing- Optum has identified a critical connectivity issue affecting transactions routed to Prime Therapeutics / Magellan. The issue is resulting in connection‑to‑payer errors and is currently preventing successful claim processing for impacted plans. Optum teams are actively engaged and working with the payer to restore connectivity as quickly as possible.
BIN 022659 BIN 009737/ 011503 BIN 002286
INC #INC48943150
Posted Mar 14, 2026 - 14:13 EDT
Investigating
Optum has identified a critical connectivity issue affecting transactions routed to Prime Therapeutics / Magellan. The issue is resulting in connection‑to‑payer errors and is currently preventing successful claim processing for impacted plans. Optum teams are actively engaged and working with the payer to restore connectivity as quickly as possible.
BIN 022659 BIN 009737/ 011503 BIN 002286
INC #INC48943150
Posted Mar 14, 2026 - 13:01 EDT
This incident affected: Pharmacy Solutions (Pharmacy Network Solutions).