Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 25, 2025 - 19:00 EDT
Scheduled
Clinical Exchange Self Service Tool Enhancements are scheduled for deployment June 25, 2025, 7:00 p.m. ET. The release is expected to take no more than 3 hours. During this window, attempts to log into the website or use of the product features may be disrupted.
Included in this release: • Rebranding changes (updates to colors and logo) • Bug Fix: Ignore case when sorting the facility list. • UI change: A new Customer ID field has been added to the enrollment web form. Channel Partners can use this field if they provide Optum with a unique internal ID when submitting a new practice setup. • UI change: added a One Healthcare Username column to the User section of a Live Practice. • UI Change: When the details of a Live Practice are being viewed, 2 new links are available at the top right of the screen that can navigate the user directly to the Caregivers or User sections. A blue up arrow at the bottom right of the page will take the user back to the top of the screen.
Posted Jun 23, 2025 - 15:59 EDT
This scheduled maintenance affected: Clinical Exchange.