Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 21, 2025 - 23:00 EST
Scheduled
Optum will be doing maintenance on our database. As part of that maintenance, claims and remit processing will be unavailable February 21, 2025, 10:00 p.m.-February 22, 2025, 4:00 p.m. CT.
Revenue Performance Advisor customers need to be aware of the following: • All transaction processing will be unavailable during the maintenance. This includes: o Claims o Remittance o Claim Status o Eligibility • Claims will not be delivered to the payer until the event has completed. • Remits will not be retrieved or processed from payers until the event has completed.
Action Required by You Please be advised of the maintenance schedule above and adjust your processes accordingly. Please follow your normal escalation path in the unlikely event you experience issues.
REF 16100966
Posted Feb 05, 2025 - 17:23 EST
This scheduled maintenance affected: Revenue Cycle Management (Revenue Performance Advisor).