Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 20, 2025 - 22:00 EDT
Scheduled
The Clinical Exchange Cloverleaf application will be unavailable on August 20th between approximately 9 p.m. - 11:59 p.m. CT. Expected downtime is 60 minutes. All transactions will be processed when the interface is back online.
Please note: The Clinical Exchange application WILL be available during this time. This maintenance impacts the interface server only.
Posted Aug 01, 2025 - 13:55 EDT
This scheduled maintenance affected: Clinical Exchange.