Upcoming Status Page Transition


On April 26, 2026, starting at 11:00 AM ET, products will transition from this status page to a single consolidated status page. The transition is expected to take 1–2 hours.


All products will be available at https://status.optum.com, except Pharmacy products, which will transition at a later date. Thank you for your patience as we improve service visibility.

Resolved Notice: RCMFO CLEARANCE estimator is down

Incident Report for Optum Solutions

Resolved

The issue that impacted the estimator has been resolved. Thank you for your patience as our teams worked to resolve this incident.

INC#INC49049942
Posted Mar 20, 2026 - 19:40 EDT

Update

The team knows about the issue impacting the system and will provide updates when more information is available.

INC#INC49049942
Posted Mar 20, 2026 - 17:22 EDT

Identified

The team is aware of the issue affecting the system and will share updates as additional details become available. Call has been reconvened to 05:00 PM EST for further investigation.
Posted Mar 20, 2026 - 15:24 EDT

Update

The team is currently aware of an issue within the system and will provide further updates as more details are confirmed.

Incident type : Estimator is down

Incident description: Estimator is down for all customers currently, and we are working to resolve this issue as quickly as possible.

INC#INC49049942
Posted Mar 20, 2026 - 13:13 EDT

Investigating

We are aware of an issue occurring within the system. We will provide updates as more information becomes available.

Incident type : Estimator is down

Incident description: Estimator is down for all customers currently, and we are working to resolve this issue as quickly as possible.

INC#INC49049942
Posted Mar 20, 2026 - 10:54 EDT
This incident affected: Patient Financial Clearance (Clearance Patient Access).