Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice : RCM ASSURANCE - Experiencing issue with intermittent performance with Medicare Direct Entry MDE is restored.

Incident Report for Optum Solutions

Resolved

The updated scripts have been distributed and all impacted jobs have been restarted. Turnkey customers need to run EPD to receive the fix, then restart failed jobs.
Posted Mar 02, 2026 - 14:49 EST

Monitoring

Updated scripts have been tested and distributed to production. Support has started resuming failed jobs. Further updates will be provided at 2PM CST.

INC/CSA/Ref # INC48697869
Posted Mar 02, 2026 - 13:15 EST

Identified

Fix is ready, working on getting up to our distribution server now.

INC/CSA/Ref # INC48697869
Posted Mar 02, 2026 - 12:18 EST

Update

We are working on correcting our process to accommodate the changes made to the MDE System.

INC/CSA/Ref # INC48697869
Posted Mar 02, 2026 - 11:12 EST

Investigating

Assurance Reimbursement Management is experiencing an issue with intermittent performance with Medicare Direct Entry (MDE).

This may result in: Failed, queued, slow jobs
ERROR: Unrecognized screen encountered after screen 'edsnet_blankscreen'
Optum is working to resolve this issue. We will notify you as soon as additional information becomes available.

We apologize for any inconvenience.

INC/CSA/Ref # INC48697869
Posted Mar 02, 2026 - 09:45 EST
This incident affected: Revenue Cycle Management (Assurance Reimbursement Management).