For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved_ Pharmacy Solutions Self Service Portal

Incident Report for Optum Solutions

Resolved

Resolved: Customers are now able to successfully create cases from the Self Service portal.
Posted Feb 06, 2025 - 15:06 EST

Identified

"Update: Customers utilizing the Self-Service Customer Portal may have difficulty opening new cases due to the product name search field. We are currently working to resolve this issue."
Posted Feb 06, 2025 - 11:15 EST

Investigating

"Customers utilizing the Self-Service Customer Portal are currently unable to open new cases. We are currently working to resolve this issue."
Posted Feb 06, 2025 - 10:37 EST
This incident affected: Pharmacy Solutions (Absolute AR, MedRx, Rx Network Solutions).