This issue is resolved and documents are processing successfully.
Posted Dec 03, 2024 - 10:39 EST
Update
Update: The team continues to work on resolving this issue. We will continue to provide updates as we resolve this issue.
Posted Dec 02, 2024 - 16:05 EST
Update
Update: The team continues to work on resolving this issue. The scope has been confirmed to be limited to payments we have received after Wed., Nov. 27 at 7 p.m. ET.
The next update will be provided by 4 p.m. or as soon as the issue is resolves.
Posted Dec 02, 2024 - 14:02 EST
Investigating
Dec. 2, 2024, 11:39 a.m. ET, we are currently experiencing a problem processing documents. We have identified the problem and are working to quickly resolve the issue to avoid any delays with printing and mailing. The next update will be provided at 2 p.m. ET. We apologize for the inconvenience this situation has caused for you.
INC0658576
Posted Dec 02, 2024 - 12:07 EST
This incident affected: Payer Communications and Payment Services (Communications Complete - Payer).