For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved: Real-time eligibility transaction processing issue
Incident Report for Optum Solutions
Resolved
This incident has been resolved.
Posted Oct 08, 2024 - 17:48 EDT
Investigating
Oct. 8, 2024, 10:30 a.m. ET, real-time eligibility transaction processing are failing for multiple payers. Some customers may be unable to to request or receive real time eligibility or real time status data claim status. Optum is currently troubleshooting the issue.

INC 0628572
Posted Oct 08, 2024 - 10:55 EDT
This incident affected: Medical Network Services (eligibility, enrollment and clearinghouse) (Real-time eligibility transactions).