Optum Insight has identified the cause of the eligibility issue, and has implemented a resolution. Eligibility checks and responses are now transacting normally.
Posted Nov 10, 2025 - 14:22 EST
Investigating
Optum Insight has identified an issue causing timeouts for eligibility checks on claims billed to Commercial and Medicaid MedRx plans. We are investigating the issue and will provide an update as soon as possible.
Posted Nov 10, 2025 - 13:40 EST
This incident affected: Pharmacy Solutions (MedRx).