Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved - Multiple Products Being Impacted

Incident Report for Optum Solutions

Resolved

We believe the outage impacting Microsoft Azure services has now been resolved and our Optum applications are fully restored. Throughout the day, our teams worked diligently in close coordination with Microsoft to monitor and address the situation as it evolved. As of now, all previously impacted services appear to be operating normally, though our teams are monitoring them vigilantly. If you experience any lingering issues, please contact our support team for assistance.
Posted Oct 29, 2025 - 21:52 EDT

Monitoring

Our teams continue to work closely to monitor the situation with Microsoft. We are now starting to see phased restoration on many of our impacted applications. We appreciate your patience as we work to fully validate restoration of all services and will send more information as it becomes available.
Posted Oct 29, 2025 - 17:18 EDT

Identified

We are aware of a widespread outage involving Microsoft Azure. Our teams are currently working closely to monitor the situation with Microsoft to minimize any impact to our environment. We appreciate your patience as we work to resolve this issue as quickly as possible
Posted Oct 29, 2025 - 15:23 EDT

Update

The cloud service provider is rolling back recent changes and restoring services to their last known good state. Many Optum applications remain impacted. We will share further updates as soon as more information becomes available.
Posted Oct 29, 2025 - 13:51 EDT

Update

A major cloud service provider is experiencing a DNS-related outage that is disrupting access to its management portal and multiple services. The issue began around 12 PM Eastern Time and is currently impacting all Optum applications. The provider is working to resolve the problem, and we will share updates as soon as additional information becomes available.
Posted Oct 29, 2025 - 12:50 EDT

Investigating

We’re currently experiencing performance issues affecting several Optum applications. Our technical teams are actively working to resolve the problem. We’ll share updates as soon as more information is available.
Posted Oct 29, 2025 - 12:36 EDT
This incident affected: CareSelect®, Clinical Exchange, Contract Manager, Dental Network, HealthQx, InterQual, Provider Manager, Reimbursement Manager, Risk Manager, Risk View, SmartPay Plus, Pharmacy Solutions (Absolute AR, MedRx, Pharmacy Data Solutions, Pharmacy Network Solutions, Pharmacy Software Solutions), Revenue Cycle Management (AccuPost, Acuity Revenue Cycle Analytics, Assurance Reimbursement Management, Revenue Performance Advisor), Patient Financial Clearance (AHI QA & Lobby, Clearance Patient Access, EngageCare Provider), and Medical Network (Real Time).