Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice: ACCUREG - ENGAGECARE PROVIDER Login issue

Incident Report for Optum Solutions

Resolved

Teams have identified the login issue and resolve it. Customers are now able to login to the Engage Care Provider product. We apologize for the disruption this has caused and appreciate your patience while teams resolved it.

INC/CSA/Ref #INC48061955
Posted Jan 28, 2026 - 09:49 EST

Investigating

Advise customer's that we are currently experiencing a Login issue after the 7.12.9 EngageCare Upgrade for Multitenancy and teams are engaged to resolve the issue as quickly as possible.

INC/CSA/Ref #INC48061955
Posted Jan 28, 2026 - 09:20 EST
This incident affected: Patient Financial Clearance (EngageCare Provider).