For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved: Assurance Reimbursement Management Performance Issue
Incident Report for Optum Solutions
Resolved
This incident has been resolved
Posted Oct 14, 2024 - 13:08 EDT
Investigating
Assurance Reimbursement Management is experiencing an issue with intermittent performance.

This may result in:

•Error upon login

Optum is working to resolve this issue. We will notify you as soon as additional information becomes available.

We apologize for any inconvenience.

Action Required: Clear browser cache and retry login.

INC39409020 REF 783450
Posted Sep 24, 2024 - 08:09 EDT
This incident affected: Revenue Cycle Management (Assurance Reimbursement Management).