For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved: AbsoluteAR Intermittent Performance Issue

Incident Report for Optum Solutions

Resolved

Dear Valued Customer,

The Absolute AR Website incident has been resolved. An internal application was restarted and this has resolved the issue. We appreciate your patience while we worked to resolve the user experience.

Wishing you a great day,
Absolute AR Team
Posted Apr 15, 2025 - 15:30 EDT

Investigating

Dear Valued Customer,

We are aware of sporadic issues within the Absolute AR website causing slowness. We are working with internal teams to resolve the issue. We will continue to give timely updates until the issue is resolved.

Thank you,

Absolute AR Team

REF 17276958
Posted Apr 15, 2025 - 14:45 EDT
This incident affected: Pharmacy Solutions (Absolute AR).