Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice: Multiple Products Impacted - Service Outage

Incident Report for Optum Solutions

Resolved

No additional impacts have been identified by Cloudflare or Optum. All Optum products are fully available, and the issue caused by Cloudflare has been resolved.
Posted Nov 18, 2025 - 10:01 EST

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 09:57 EST

Monitoring

Cloudflare has moved all UHG accounts from the new version of its frontline proxy back to the previous version to restore service. Our teams are actively monitoring and verifying that all products across the organization are fully restored. We will provide a resolution update within approximately one hour, assuming the issue does not reoccur.
Posted Nov 18, 2025 - 09:47 EST

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 09:23 EST

Identified

Cloudflare has identified a resolution, and engineers are preparing to deploy the fix. Deployment is expected to begin at approximately 9:15 AM ET. We will share additional information and updates once the deployment is underway.
Posted Nov 18, 2025 - 09:18 EST

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 08:56 EST

Investigating

We are aware of a service disruption affecting multiple Optum products. Our vendor, Cloudflare, is currently experiencing a partial outage and is actively investigating the issue. We are monitoring the situation closely and will share updates as soon as they become available.
Posted Nov 18, 2025 - 07:34 EST
This incident affected: Pharmacy Solutions (MedRx), Revenue Cycle Management (Acuity Revenue Cycle Analytics, Assurance Reimbursement Management, TES Ambulatory), and InterQual.