Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice: INTERQUAL CONNECT AWS (PROD) (CHC) - Interqual Connect/Cloud- Service Outage

Incident Report for Optum Solutions

Resolved

The issue that was preventing users from accessing InterQual has been resolved. If you are still experiencing issues, please clear your browser cache and try again. If the issue persists, please contact Product Support.

#INC48798457
Posted Mar 06, 2026 - 11:16 EST

Investigating

We are currently investigating an issue impacting InterQual Connect customers using prod.ds.interqual.com or prod2.ds.interqual.com, where users are receiving blank screen or error when they launch InterQual. Our team is actively working to identify and resolve the problem. We will provide additional information as our investigation progresses.

Current Status: We are currently investigating this issue. Additional information will be provided as we make progress towards a resolution.

#INC48798457
Posted Mar 06, 2026 - 11:04 EST
This incident affected: InterQual.