For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved: Clearance Patient Access Suite/Ahi Performance Issue

Incident Report for Optum Solutions

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 09:10 EDT

Investigating

Optum is experiencing an issue with performance for Clearance and AHI.

This may result in:
• 502 Bad Gateway errors
• Inability to log into Clearance
• Inability to log into Ahi

Optum is working to resolve this issue. We will notify you as soon as additional information becomes available.

We apologize for any inconvenience.

REF 17016358
Posted Mar 26, 2025 - 08:40 EDT
This incident affected: Revenue Cycle Management (AhiQA, Clearance Patient Access Suite).