For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Correction: InterQual® Cloud Solutions August 23, 2024 Software Release
Scheduled for Aug 23, 23:00 - 23:10 EDT
Update
Correction: InterQual® Cloud Solutions August 23, 2024 Software Release at 11 p.m. ET

Scheduled - This message is intended for InterQual® Cloud Solutions customers.

We are pleased to announce the August 23, 2024 release of the InterQual® Cloud solutions, which includes these updates:
• Latest subset version is now automatically selected on the Subset Overview screen
• InterQual® Connect Medical Review Service API v2.2
• Enhanced display of clinical data in InterQual® AutoReview automated reviews

Visit the What’s New page on the InterQual® Resource Center to learn more about these updates for the products listed below:
• InterQual® Connect Medical Review Service
• InterQual® AutoReview
• InterQual® Anonymous Review
• InterQual® Transparency
• InterQual® Online
• InterQual® Mobile

Contact Information
For any additional information or assistance, log in to the Customer Care Hub and submit a new case to Product Support.

REF 756850
Posted Aug 20, 2024 - 13:42 EDT
Scheduled
This message is intended for InterQual® Cloud Solutions customers.

We are pleased to announce the August 2024 release of the InterQual® Cloud solutions, which includes these updates:
• Latest subset version is now automatically selected on the Subset Overview screen
• InterQual® Connect Medical Review Service API v2.2
• Enhanced display of clinical data in InterQual® AutoReview automated reviews

Visit the What’s New page on the InterQual® Resource Center to learn more about these updates for the products listed below:

• InterQual® Connect Medical Review Service
• InterQual® AutoReview
• InterQual® Anonymous Review
• InterQual® Transparency
• InterQual® Online
• InterQual® Mobile

Contact Information For any additional information or assistance, log in to the Customer Care Hub and submit a new case to Product Support.

REF 756850 8/20/2024
Posted Aug 23, 2024 - 23:00 EDT
This scheduled maintenance affects: Clinical Decision Support (InterQual® Cloud Solutions).