For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved: Clinical Exchange Quest results processing delays

Incident Report for Optum Solutions

Resolved

This issue is resolved. Quest results processing is now caught up.
Posted May 05, 2025 - 15:12 EDT

Monitoring

Update: Quest results are processing and we expect to have all results processed by this afternoon.

We will send an update when all results have been processed.
Posted May 05, 2025 - 14:09 EDT

Investigating

Quest results processing for all Clinical Exchange customers is currently delayed. This is only impacting Quest results

We are working to resolve this issue as quickly as possible.

REF 17521127
Posted May 05, 2025 - 11:16 EDT
This incident affected: Clinical Network (Clinical Exchange Channel Partners including ePrescribe and Orders & Results, Clinical Exchange Labs and Hospitals).