Resolved
Most AWS services have been restored and internal systems are now operating normally. AWS continues to issue updates, and the Optum support teams remain vigilant, actively monitoring for any residual or emerging issues to ensure stability. We appreciate your patience and apologize for any inconvenience caused.
Posted Oct 20, 2025 - 19:06 EDT
Update
Optum is currently experiencing intermittent performance issues due to an AWS service interruption. As a result, customers may be experiencing sporadic connectivity and performance with Optum products including call center phones and chat features.
Optum is working to resolve this issue. We will notify you as soon as additional information becomes available.
We apologize for any inconvenience.
Posted Oct 20, 2025 - 17:30 EDT
Investigating
Optum is currently experiencing intermittent performance issues due to an AWS service interruption. As a result, customers may be experiencing sporadic connectivity and performance with Optum products including call center phones and chat features.
Optum is working to resolve this issue. We will notify you as soon as additional information becomes available.
We apologize for any inconvenience.
Posted Oct 20, 2025 - 13:58 EDT
This incident affected: CareSelect®, Clinical Exchange, Contract Manager, Dental Network, HealthQx, InterQual, Provider Manager, Reimbursement Manager, Risk Manager, Risk View, SmartPay Plus, Pharmacy Solutions (Absolute AR, MedRx, Pharmacy Data Solutions, Pharmacy Network Solutions, Pharmacy Software Solutions), Revenue Cycle Management (AccuPost, Acuity Revenue Cycle Analytics, Assurance Reimbursement Management, Revenue Performance Advisor), Patient Financial Clearance (AHI QA & Lobby, Clearance Patient Access, EngageCare Provider), and Medical Network (Batch, Real Time).