Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice- Clinical Exchange- delay with results processing

Incident Report for Optum Solutions

Resolved

All results have been processed. Thank you for your patience as our teams worked to resolve this issue.
Posted Dec 18, 2025 - 11:13 EST

Identified

Results are now processing as expected and the issue is still being investigated. We will provide updates as more information becomes available.
Posted Dec 18, 2025 - 10:57 EST

Investigating

Clinical Exchange is currently experiencing an issue that is impacting results processing. While the application is online and orders are processing as expected, there is a delay with results processing. We will provide updates as more information becomes available.

#INC47259235
Posted Dec 18, 2025 - 09:43 EST
This incident affected: Clinical Exchange.