For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved Incident: Assurance Reimbursement Management Medicare Direct Entry (MDE) Performance Issue

Incident Report for Optum Solutions

Resolved

This issue has been resolved, and performance has returned to optimal levels. Optum has resolved all impacted jobs for hosted clients.

Turnkey clients will need to review their Job Queue for any failed Release jobs. If assistance is needed, please reach out to Support.
Posted Apr 07, 2025 - 14:15 EDT

Investigating

Assurance Reimbursement Management is experiencing an issue with intermittent performance with Medicare Direct Entry (MDE).

This may result in:
• Failed, queued, slow jobs
• ERROR: Unrecognized screen encountered after screen 'edsnet_SignOnComplete'

Optum is working to resolve this issue. We will notify you as soon as additional information becomes available.

We apologize for any inconvenience.

Action Required: None.

REF 17161908
Posted Apr 07, 2025 - 10:30 EDT
This incident affected: Revenue Cycle Management (Assurance Reimbursement Management).