For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved: Medical Necessity Performance Issue

Incident Report for Optum Solutions

Resolved

This incident has been resolved.
Posted May 05, 2025 - 14:50 EDT

Investigating

Clearance Patient Access Suite is experiencing a performance issue with Medical Necessity. This may result in:

CPT code Codefinder search not processing

Optum is working to resolve this issue. We will notify you as soon as additional information becomes available.
Posted May 05, 2025 - 10:49 EDT
This incident affected: Revenue Cycle Management (Clearance Patient Access Suite: Medical Necessity).