For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Rescheduled: Clinical Exchange System Maintenance Dec. 3, 2024
Scheduled for Dec 3, 22:00 EST  -  Dec 4, 01:00 EST
Update
Optum will administer system maintenance impacting normal Clinical Exchange services according to the maintenance schedule below:

Maintenance Schedule:
Begin: Tues., Dec. 3, 2024, 10 p.m. ET
End: Wed., Dec. 4, 2024, 1 a.m. ET
(Duration of 3 hours)

The Clinical Exchange product may be unavailable for brief periods during maintenance.
Posted Nov 14, 2024 - 17:05 EST
Scheduled
Optum will administer system maintenance impacting normal Clinical Exchange services according to the maintenance schedule below:

Maintenance Schedule:
Begin: Tues., Nov. 19, 2024, 10 p.m. ET
End: Wed., Nov. 20, 2024, 1 a.m. ET
(Duration of 3 hours)

The Clinical Exchange product may be unavailable for brief periods during maintenance.

REF 811600
Posted Nov 08, 2024 - 12:41 EST
This scheduled maintenance affects: Clinical Network (Clinical Exchange Channel Partners including ePrescribe and Orders & Results).