Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 07, 2025 - 23:00 EDT
Scheduled
This message is intended for InterQual® Installed Review Manager customers.
We are pleased to announce that the InterQual 2025 March content release is available for InterQual® Installed Review Manager customers as of Monday April 7, 2025.
This content release includes updates to the following modules:
For clinical revisions and additional details about this release, go to the What’s New page on InterQual® Community, select InterQual Content Releases, and then Learn more. See the section below for more information on InterQual Community.
InterQual® Review Manager and InterQual® View The InterQual 2025 content release is the final content release supported by both InterQual Review Manager and InterQual View.
The content update package file with release notes and upgrade instructions are now available on Download Connect.
Multiple options have been established to help Review Manager and InterQual View customers migrate to alternative InterQual software solutions before the InterQual 2026 content release. Contact your account manager or Product Support to learn more about these options.
InterQual® Community The new InterQual Community is now available! As a Community member you will:
• Have access to InterQual clinical documentation and resources. • Have access to active discussion forums with Optum product experts and fellow customers. • Find and connect with your peers by product and role.
The InterQual® Resource Center is being retired. Register now for the InterQual Community to stay connected and informed, and to ensure you don’t lose access to vital documentation and resources.
You should have already received an email from donotreply@optum.com with the subject line: “Complete Your Registration to Access Optum Enterprise Customer Community”. This email will include your unique registration link. Click the link to complete your setup using your One Healthcare ID (OHID). Note: the unique registration link will be active for a limited time, so please access the link to complete registration immediately upon receipt.
Don’t have an OHID yet? No problem! You can create one now at One Healthcare ID or follow the instructions in the registration invitation.
Contact information For any additional information or assistance, log in to the Customer Care Hub and submit a new case to Product Support. Product Support is also available by email at interqualsupport@optum.com and by phone at 1-800-CRITERIA (274-8374).
REF 17161506
Posted Apr 07, 2025 - 11:56 EDT
This scheduled maintenance affected: Clinical Decision Support (InterQual® Review Manager – Installed).