Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice: CLINICAL EXCHANGE - Customer reporting that they were getting a service unavailable

Incident Report for Optum Solutions

Resolved

Intermittent access issues are resolved as of 3:45 PM CT.

INC/CSA/Ref # INC46190677
Posted Oct 24, 2025 - 17:28 EDT

Identified

Intermittent access issues are resolved as of 3:45 PM CT. We will continue to monitor the system

INC/CSA/Ref # INC46190677
Posted Oct 24, 2025 - 17:18 EDT

Investigating

We are aware of intermittent reports of users unable to access the Clinical Exchange portal.


INC/CSA/Ref # INC46190677
Posted Oct 24, 2025 - 16:59 EDT
This incident affected: Clinical Exchange.