Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 10, 2025 - 21:00 EDT
Scheduled
This message is intended for Revenue Performance Advisor Customers.
Please be advised that the Revenue Performance Advisor (RPA) Platform will be undergoing maintenance on Saturday, May 10th 2025, from 9:00 p.m. EST - 11:30 p.m. EST requiring all processes to be shut down. All RPA services will be unavailable during this time.
Posted May 06, 2025 - 07:53 EDT
This scheduled maintenance affected: Revenue Cycle Management (Revenue Performance Advisor).