Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 10, 2025 - 21:00 EDT
Scheduled
This message is intended for InterQual® Coordinated Care customers.
The InterQual® Coordinated Care Production environments will be unavailable due to maintenance on Thursday, April 10, 2025, at 9 p.m. ET for approximately 1 hour. Users do not need to take any action but should stop their work before 9 p.m. ET or their session will be interrupted.
We appreciate your support and apologize for any inconvenience this may cause.
Updated Maintenance Schedule Begin: April 10, 2025, 9 p.m. ET End: April 10, 2025, 10 p.m. ET
Contact Information For additional information or assistance, log in to the Customer Care Hub and submit a new case to Product Support.
REF 17213509
Posted Apr 10, 2025 - 09:18 EDT
This scheduled maintenance affected: Clinical Decision Support (InterQual® Coordinated Care).