For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

InterQual® Cloud Solutions Software Release

Scheduled for Mar 13, 23:00 - 23:10 EDT

Scheduled

We are pleased to announce the release of the InterQual® Cloud solutions version 417 to production and 418 to non-production (integ). These releases include the following updates:

• Updates to user interface to align colors, fonts, and visual style with Optum branding standards.
• Updates to support benchmark setting information at the CPT® code level based on aggregate claims data and CMS setting determinations.
• InterQual® Medical Review Service for payer utilization management workflows now supports displaying different criteria based on the member’s line of business.
• Additional enhancements and details are listed on the InterQual® Resource Center What’s New page.

These releases will be deployed to the production and non-production (integ) environments Thursday, March 13, 2025, 11:00 p.m. ET.

Contact Information
For additional information or assistance, log in to the Customer Care Hub and submit a new case to Product Support.

REF 16810168
Posted Mar 11, 2025 - 15:30 EDT
This scheduled maintenance affects: Clinical Decision Support (InterQual® Cloud Solutions).