Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Optum Insight MedRX Invoice Errors

Incident Report for Optum Solutions

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 11:09 EDT

Identified

This message is intended for Pharmacy Network MedRX customers.

Optum Insight has identified an issue causing duplicate line items for MedRX products on August invoices resulting in an erroneous total amount due. Please disregard these erroneous invoices, as corrected invoices are being generated and will be sent to customers as soon as possible. We apologize for any inconvenience and are implementing steps to prevent this issue from recurring in the future.
Posted Sep 17, 2025 - 12:53 EDT
This incident affected: Pharmacy Solutions (MedRx, Pharmacy Network Solutions).