Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 15, 2025 - 00:00 EDT
Scheduled
This message is intended for Revenue Performance Advisor (RPA) customers.
In one week - Apr. 15, 2025 - your users will create professional claims using the Direct Data Entry (DDE) tool inside RPA or using a batch file in the ANSI 837 professional claim format loaded into RPA.
By now, the following should be complete: • deciding which option your organization will use • notifying the RPA representative • informing your users of the change and sharing the learning resources below
First reminder communication date The first reminder was sent Mar. 10, 2025.
Actions required • Urgent!! If you have not already determined which submission option is better for your organization, open a case in Customer Care Hub.
• Notify your team of the upcoming change and share the following learning resources:
o Create New Professional Claim video - In RPA, click the Support menu and click the Learning Center option. When the Learning Center opens, scroll to the Claims Management section and find the “Create New Professional Claim” video.
o 5010 Claims 837 companion guide - On the RPA home page, scroll down to the Resource Center. Click the Companion Guides tab and click the hyperlink for the “5010 Claims 837 Companion Guide.”
• If you don’t already have an Optum User Community account, use these instructions to request access to the User Community. Upon approval, follow the instructions to complete registration and sign in.
• RPA support information: For all questions (including which submission method is better for your organization), issues, and general inquiries for RPA, submit a case in Customer Care Hub.
REF 16169914
Posted Apr 08, 2025 - 15:58 EDT
This scheduled maintenance affected: Revenue Cycle Management (Revenue Performance Advisor).