For further updates about the Change Healthcare cybersecurity issue, please visit Change Healthcare Cyber Response.

For imaging solutions, please visit us at Change Healthcare Enterprise Imaging.

Resolved: Pharmacy Central Services Central Patient Response Time Degradation
Incident Report for Optum Solutions
Resolved
This incident is resolved.
Posted Oct 14, 2024 - 11:01 EDT
Monitoring
Optum is monitoring a resolution.

Next update will be October 12, 2024 at 11 a.m. ET
Posted Oct 11, 2024 - 18:54 EDT
Update
Optum will continue to work toward a solution to this issue.

Next update will be at 8 p.m. ET or when significant progress has been made.
Posted Oct 11, 2024 - 17:02 EDT
Update
Optum is working on a solution to this issue.

Next update will be at 5 p.m. ET or when further updates are available.
Posted Oct 11, 2024 - 15:09 EDT
Update
Optum continues to work towards a resolution to this issue.

Next update will be at 3 p.m. ET or when further updates are available.
Posted Oct 11, 2024 - 14:06 EDT
Update
Optum continues to work towards a resolution to this issue.

Next update will be at 2 p.m. ET or when further updates are available.
Posted Oct 11, 2024 - 13:19 EDT
Identified
Optum has identified the issue and is working toward a solution.

Next update will be at 1:10 p.m. ET or when further updates are available.
Posted Oct 11, 2024 - 12:42 EDT
Investigating
Pharmacy customers are currently experiencing a degradation in performance.

Optum is triaging the issue and will provide an update at 12:30 p.m. ET or when further updates are available.

We apologize for the inconvenience this situation has caused you.

INC0630417
Posted Oct 11, 2024 - 11:54 EDT
This incident affected: Pharmacy Solutions (Converge Rx, Enterprise Pharmacy System).