Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice - Medical Network Relay Exchange - Service Disruption involving Enrollment Central and the Provider Management Tool

Incident Report for Optum Solutions

Resolved

Issue with our partner is now resolved, adding new enrollments and provider creation has been restored. Thank you for your understanding and patience as we worked to resolve this matter.
Posted Nov 25, 2025 - 13:03 EST

Investigating

We’re experiencing an issue with one of our partners that may temporarily affect adding new enrollments and provider creation. We’re working to fix this quickly and appreciate your patience.

INC # INC46831590
Posted Nov 25, 2025 - 12:03 EST
This incident affected: Medical Network (Batch).