Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Issue: Clinical Exchange lab orders and results processing

Incident Report for Optum Solutions

Resolved

Clinical Exchange was currently experiencing an issue with lab orders and results. The application was available but orders and results processing were delayed.

Lab orders and results processing delays occurred June 18, 2025, 11:00 p.m.-June 19, 2025, 9:00 a.m. ET. All orders and results are now processing as expected.
Posted Jun 19, 2025 - 09:32 EDT
This incident affected: Clinical Exchange.