Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice: TES RCM MDIV / Kerberos mounts experiencing intermittent connectivity issues with MDIV

Incident Report for Optum Solutions

Resolved

Corrective actions implemented - services restored.


INC# INC48748784
Posted Mar 04, 2026 - 13:22 EST

Investigating

We are currently experiencing intermittent issues with MDIV this morning. Our AIX and MDIV engineering teams are actively working to identify the root cause and resolve the issue as quickly as possible.

Thank you for your patience and understanding while we work through this. We will share updates on any significant developments and notify you as soon as service is fully restored.


INC# INC48748784
Posted Mar 04, 2026 - 13:00 EST
This incident affected: Revenue Cycle Management (TES Ambulatory).