Welcome to our new simplified view of this Optum Solution Status page making it easier for you to quickly get the information you need.

Resolved Notice: EXPLORE DX REPORTING SERVICE (CHC) - AbsoluteAR data is not current in Explore EDW. The remediation is taking way too long.

Incident Report for Optum Solutions

Resolved

The delay in delivering the latest Absolute AR data has been resolved.
Posted Nov 01, 2025 - 09:19 EDT

Monitoring

There is currently a delay in delivering the latest Absolute AR data, which is also impacting dashboards within the Absolute application. Our team is actively working to restore functionality, and remediation efforts are expected to continue into Saturday. We will provide an update by midday Saturday. We apologize for any inconvenience caused.
Posted Nov 01, 2025 - 07:49 EDT

Update

There is currently a delay with delivery of current Absolute AR data. This also impacts dashboards within the Absolute application.
We are actively working to restore functionality; remediation will carry into Saturday. We will send another update midday Saturday. We apologize for any inconvenience.
Posted Oct 31, 2025 - 22:21 EDT

Identified

There is currently a delay with delivery of current Absolute AR data. This also impacts dashboards within the Absolute application.
We are actively working to restore functionality as quickly as possible and remediation continues. We apologize for any inconvenience.
Posted Oct 31, 2025 - 16:19 EDT

Update

There is currently a delay with delivery of current Absolute AR data. This also impacts dashboards within the Absolute application.
We are actively working to restore functionality as quickly as possible and will have another update after 3:30pm CST. We apologize for any inconvenience.
Posted Oct 31, 2025 - 13:48 EDT

Update

There is currently a delay with delivery of current Absolute AR data. This also impacts dashboards within the Absolute application.
We are actively working to restore functionality as quickly as possible. We apologize for any inconvenience.
Posted Oct 31, 2025 - 12:47 EDT

Investigating

There is currently a delay with delivery of current Absolute AR data. This also impacts dashboards within the Absolute application.
We are actively working to restore functionality as quickly as possible. We apologize for any inconvenience.


INC/CSA/Ref # INC46323896
Posted Oct 31, 2025 - 11:48 EDT
This incident affected: Pharmacy Solutions (Absolute AR).